const regex = /(?<=\D|\b)\d{6}(?=\D|\b)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\D|\\b)\\d{6}(?=\\D|\\b)', 'gi')
const str = `123456
blab12345alabla
123456
blab123456labla
blab1234567abla
blab123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}