re = /(?<=\D|\b)\d{6}(?=\D|\b)/i
str = '123456
blab12345alabla
123456
blab123456labla
blab1234567abla
blab123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end