import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\D|\\b)\\d{6}(?=\\D|\\b)";
final String string = "123456\n"
+ "blab12345alabla\n"
+ " 123456\n"
+ "blab123456labla\n"
+ "blab1234567abla\n"
+ "blab123456";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}