$re = '/(?<=\D|\b)\d{6}(?=\D|\b)/i';
$str = '123456
blab12345alabla
123456
blab123456labla
blab1234567abla
blab123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);