#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^SCHEDULE\b.*(?:\n(?!(?:.*#\/.*E|END)$).*)*\r?\n.*#\/.*E\r?\n[^\S\r\n]*NOP(?:\r?\n(?!END$).*)*\r?\nEND$"
Local $sString = "SCHEDULE MANAGER_XA#KAAABBBR " & @CRLF & _
"DESCRIPTION "Added by default."" & @CRLF & _
"ON RUNCYCLE KAAABBBR VALIDTO 09/24/2021 $RCG KAAABBBR" & @CRLF & _
":" & @CRLF & _
"S89AAAABBB1#/XAAA/XCCCDDDD/KA0EG014" & @CRLF & _
" FOLLOWS KABBBCCC3" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"S89AAAABBB1#/XAAA/XCCCDDDD/KAHHHTTTTTE" & @CRLF & _
" NOP" & @CRLF & _
" FOLLOWS KABBBCCC3" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"S89AAAABBB1#/XAAA/XCCCDDDD/KAHHHTTTTTS" & @CRLF & _
" NOP" & @CRLF & _
" FOLLOWS MANAGER_XA#KZZZDDDD.KGGGHHHHHE " & @CRLF & _
"" & @CRLF & _
"END" & @CRLF & _
"" & @CRLF & _
"SCHEDULE MANAGER_XA#KBBBCCCR " & @CRLF & _
"DESCRIPTION "Added by default."" & @CRLF & _
"ON RUNCYCLE KAAABBBR VALIDTO 09/24/2021 $RCG KBBBCCCR " & @CRLF & _
":" & @CRLF & _
"S89AAAABBB1#/XBBB/XCCCDDDD/KA0EG014" & @CRLF & _
" FOLLOWS KABBBCCC3" & @CRLF & _
"" & @CRLF & _
"S89AAAABBB1#/XBBB/XCCCDDDD/KAHHHTTTE" & @CRLF & _
" FOLLOWS KABBBCCC3" & @CRLF & _
"" & @CRLF & _
"S89AAAABBB1#/XBBB/XCCCDDDD/KAHHHTTTTTS" & @CRLF & _
" NOP" & @CRLF & _
" FOLLOWS MANAGER_XA#KZZZDDDD.KGGGHHHHHE " & @CRLF & _
"" & @CRLF & _
"END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")