use strict;
my $str = 'SCHEDULE MANAGER_XA#KAAABBBR
DESCRIPTION "Added by default."
ON RUNCYCLE KAAABBBR VALIDTO 09/24/2021 $RCG KAAABBBR
:
S89AAAABBB1#/XAAA/XCCCDDDD/KA0EG014
FOLLOWS KABBBCCC3
S89AAAABBB1#/XAAA/XCCCDDDD/KAHHHTTTTTE
NOP
FOLLOWS KABBBCCC3
S89AAAABBB1#/XAAA/XCCCDDDD/KAHHHTTTTTS
NOP
FOLLOWS MANAGER_XA#KZZZDDDD.KGGGHHHHHE
END
SCHEDULE MANAGER_XA#KBBBCCCR
DESCRIPTION "Added by default."
ON RUNCYCLE KAAABBBR VALIDTO 09/24/2021 $RCG KBBBCCCR
:
S89AAAABBB1#/XBBB/XCCCDDDD/KA0EG014
FOLLOWS KABBBCCC3
S89AAAABBB1#/XBBB/XCCCDDDD/KAHHHTTTE
FOLLOWS KABBBCCC3
S89AAAABBB1#/XBBB/XCCCDDDD/KAHHHTTTTTS
NOP
FOLLOWS MANAGER_XA#KZZZDDDD.KGGGHHHHHE
END';
my $regex = qr/^SCHEDULE\b.*(?:\n(?!(?:.*#\/.*E|END)$).*)*\r?\n.*#\/.*E\r?\n[^\S\r\n]*NOP(?:\r?\n(?!END$).*)*\r?\nEND$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}