re = /^SCHEDULE\b.*(?:\n(?!(?:.*#\/.*E|END)$).*)*\r?\n.*#\/.*E\r?\n[^\S\r\n]*NOP(?:\r?\n(?!END$).*)*\r?\nEND$/m
str = 'SCHEDULE MANAGER_XA#KAAABBBR
DESCRIPTION "Added by default."
ON RUNCYCLE KAAABBBR VALIDTO 09/24/2021 $RCG KAAABBBR
:
S89AAAABBB1#/XAAA/XCCCDDDD/KA0EG014
FOLLOWS KABBBCCC3
S89AAAABBB1#/XAAA/XCCCDDDD/KAHHHTTTTTE
NOP
FOLLOWS KABBBCCC3
S89AAAABBB1#/XAAA/XCCCDDDD/KAHHHTTTTTS
NOP
FOLLOWS MANAGER_XA#KZZZDDDD.KGGGHHHHHE
END
SCHEDULE MANAGER_XA#KBBBCCCR
DESCRIPTION "Added by default."
ON RUNCYCLE KAAABBBR VALIDTO 09/24/2021 $RCG KBBBCCCR
:
S89AAAABBB1#/XBBB/XCCCDDDD/KA0EG014
FOLLOWS KABBBCCC3
S89AAAABBB1#/XBBB/XCCCDDDD/KAHHHTTTE
FOLLOWS KABBBCCC3
S89AAAABBB1#/XBBB/XCCCDDDD/KAHHHTTTTTS
NOP
FOLLOWS MANAGER_XA#KZZZDDDD.KGGGHHHHHE
END'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end