import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^SCHEDULE\\b.*(?:\\n(?!(?:.*#\\/.*E|END)$).*)*\\r?\\n.*#\\/.*E\\r?\\n[^\\S\\r\\n]*NOP(?:\\r?\\n(?!END$).*)*\\r?\\nEND$";
final String string = "SCHEDULE MANAGER_XA#KAAABBBR \n"
+ "DESCRIPTION \"Added by default.\"\n"
+ "ON RUNCYCLE KAAABBBR VALIDTO 09/24/2021 $RCG KAAABBBR\n"
+ ":\n"
+ "S89AAAABBB1#/XAAA/XCCCDDDD/KA0EG014\n"
+ " FOLLOWS KABBBCCC3\n\n\n"
+ "S89AAAABBB1#/XAAA/XCCCDDDD/KAHHHTTTTTE\n"
+ " NOP\n"
+ " FOLLOWS KABBBCCC3\n\n\n"
+ "S89AAAABBB1#/XAAA/XCCCDDDD/KAHHHTTTTTS\n"
+ " NOP\n"
+ " FOLLOWS MANAGER_XA#KZZZDDDD.KGGGHHHHHE \n\n"
+ "END\n\n"
+ "SCHEDULE MANAGER_XA#KBBBCCCR \n"
+ "DESCRIPTION \"Added by default.\"\n"
+ "ON RUNCYCLE KAAABBBR VALIDTO 09/24/2021 $RCG KBBBCCCR \n"
+ ":\n"
+ "S89AAAABBB1#/XBBB/XCCCDDDD/KA0EG014\n"
+ " FOLLOWS KABBBCCC3\n\n"
+ "S89AAAABBB1#/XBBB/XCCCDDDD/KAHHHTTTE\n"
+ " FOLLOWS KABBBCCC3\n\n"
+ "S89AAAABBB1#/XBBB/XCCCDDDD/KAHHHTTTTTS\n"
+ " NOP\n"
+ " FOLLOWS MANAGER_XA#KZZZDDDD.KGGGHHHHHE \n\n"
+ "END";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}