#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-(START(?:_[^_]+){2,3})_\d+(?=-END)"
Local $sString = "test-START_one_4-END" & @CRLF & _
"test-START_one_two_three_4-END" & @CRLF & _
"test-START_one_two_4-END" & @CRLF & _
"test-START_one_two_three_4-END" & @CRLF & _
"test-START_one_two_three_four_4-END" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")