re = /-(START(?:_[^_]+){2,3})_\d+(?=-END)/m
str = 'test-START_one_4-END
test-START_one_two_three_4-END
test-START_one_two_4-END
test-START_one_two_three_4-END
test-START_one_two_three_four_4-END
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end