using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-(START(?:_[^_]+){2,3})_\d+(?=-END)";
string input = @"test-START_one_4-END
test-START_one_two_three_4-END
test-START_one_two_4-END
test-START_one_two_three_4-END
test-START_one_two_three_four_4-END
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}