use strict;
my $str = 'test-START_one_4-END
test-START_one_two_three_4-END
test-START_one_two_4-END
test-START_one_two_three_4-END
test-START_one_two_three_four_4-END
';
my $regex = qr/-(START(?:_[^_]+){2,3})_\d+(?=-END)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}