using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\""WAFFlags\"":\""1\""|\""FirewallMatchesActions\"":\[\""log\""\]|\""FirewallMatchesActions\"":\[\""log\"",\""log\""\]|\""FirewallMatchesSources\"":\[\""firewallRules\"",\""waf\""\])";
string input = @"""WAFFlags"":""1""
""FirewallMatchesActions"":[""log""]
""FirewallMatchesActions"":[""log"",""log""]
""FirewallMatchesSources"":[""firewallRules"",""waf""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}