$re = '/(\"WAFFlags\":\"1\"|\"FirewallMatchesActions\":\[\"log\"\]|\"FirewallMatchesActions\":\[\"log\",\"log\"\]|\"FirewallMatchesSources\":\[\"firewallRules\",\"waf\"\])/m';
$str = '"WAFFlags":"1"
"FirewallMatchesActions":["log"]
"FirewallMatchesActions":["log","log"]
"FirewallMatchesSources":["firewallRules","waf"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);