package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\"WAFFlags\":\"1\"|\"FirewallMatchesActions\":\[\"log\"\]|\"FirewallMatchesActions\":\[\"log\",\"log\"\]|\"FirewallMatchesSources\":\[\"firewallRules\",\"waf\"\])`)
var str = `"WAFFlags":"1"
"FirewallMatchesActions":["log"]
"FirewallMatchesActions":["log","log"]
"FirewallMatchesSources":["firewallRules","waf"]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}