// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\"WAFFlags\":\"1\"|\"FirewallMatchesActions\":\[\"log\"\]|\"FirewallMatchesActions\":\[\"log\",\"log\"\]|\"FirewallMatchesSources\":\[\"firewallRules\",\"waf\"\])"#).unwrap();
let string = "\"WAFFlags\":\"1\"
\"FirewallMatchesActions\":[\"log\"]
\"FirewallMatchesActions\":[\"log\",\"log\"]
\"FirewallMatchesSources\":[\"firewallRules\",\"waf\"]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}