import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\"WAFFlags\\\":\\\"1\\\"|\\\"FirewallMatchesActions\\\":\\[\\\"log\\\"\\]|\\\"FirewallMatchesActions\\\":\\[\\\"log\\\",\\\"log\\\"\\]|\\\"FirewallMatchesSources\\\":\\[\\\"firewallRules\\\",\\\"waf\\\"\\])";
final String string = "\"WAFFlags\":\"1\"\n"
+ "\"FirewallMatchesActions\":[\"log\"]\n"
+ "\"FirewallMatchesActions\":[\"log\",\"log\"]\n"
+ "\"FirewallMatchesSources\":[\"firewallRules\",\"waf\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}