#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?=.*plus)(?!.*iphone 12)"
Local $sString = "test-title iphone 13 plus" & @CRLF & _
"test-title iphone 13" & @CRLF & _
"test-title iphone 12 plus" & @CRLF & _
"test-title iphone 14 plus" & @CRLF & _
"test-title iphone 14" & @CRLF & _
"test-title ipad" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")