const regex = new RegExp('(?i)^(?=.*plus)(?!.*iphone 12)', 'gm')
const str = `test-title iphone 13 plus
test-title iphone 13
test-title iphone 12 plus
test-title iphone 14 plus
test-title iphone 14
test-title ipad
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}