import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(?=.*plus)(?!.*iphone 12)";
final String string = "test-title iphone 13 plus\n"
+ "test-title iphone 13\n"
+ "test-title iphone 12 plus\n"
+ "test-title iphone 14 plus\n"
+ "test-title iphone 14\n"
+ "test-title ipad\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}