re = /(?i)^(?=.*plus)(?!.*iphone 12)/m
str = 'test-title iphone 13 plus
test-title iphone 13
test-title iphone 12 plus
test-title iphone 14 plus
test-title iphone 14
test-title ipad
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end