import re
regex = re.compile(r"(?i)^(?=.*plus)(?!.*iphone 12)", flags=re.MULTILINE)
test_str = ("test-title iphone 13 plus\n"
"test-title iphone 13\n"
"test-title iphone 12 plus\n"
"test-title iphone 14 plus\n"
"test-title iphone 14\n"
"test-title ipad\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")