# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^|$)\b|(?!\w)\B(?!\w)/\n/gm;t' <<< "123.456.789;abc;.xyz.;ABC"