re = /(?!^|$)\b|(?!\w)\B(?!\w)/m
str = '123.456.789;abc;.xyz.;ABC'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result