const regex = /(?!^|$)\b|(?!\w)\B(?!\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^|$)\\b|(?!\\w)\\B(?!\\w)', 'gm')
const str = `123.456.789;abc;.xyz.;ABC`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);