use strict;
my $str = '123.456.789;abc;.xyz.;ABC';
my $regex = qr/(?!^|$)\b|(?!\w)\B(?!\w)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";