using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^|$)\b|(?!\w)\B(?!\w)";
string substitution = @"\n";
string input = @"123.456.789;abc;.xyz.;ABC";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}