import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(/v3/assets/)(.*?)(/)(.*?)(/)(.*?)(/.*?)(\\?.*?\\\"|\\\")";
final String string = "src=\"https://eu-images.contentstack.com/v3/assets/blt69509c9116440be8/bltef0f9e1a32e09046/6468057000cbe421c7ef59f6/chess-1314359_1280.jpg\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}