# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(/v3/assets/)(.*?)(/)(.*?)(/)(.*?)(/.*?)(\?.*?\"|\")"
test_str = "src=\"https://eu-images.contentstack.com/v3/assets/blt69509c9116440be8/bltef0f9e1a32e09046/6468057000cbe421c7ef59f6/chess-1314359_1280.jpg\" "
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.