// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(/v3/assets/)(.*?)(/)(.*?)(/)(.*?)(/.*?)(\?.*?\"|\")"#).unwrap();
let string = "src=\"https://eu-images.contentstack.com/v3/assets/blt69509c9116440be8/bltef0f9e1a32e09046/6468057000cbe421c7ef59f6/chess-1314359_1280.jpg\" ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}