#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxi)^123-(?:(?!a[a-z]*-)\w+-)?456$"
Local $sString = "123-456" & @CRLF & _
"123-7-456" & @CRLF & _
"123-Apple-456" & @CRLF & _
"123-0-456" & @CRLF & _
"123-Alphabet-456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")