using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^123-(?:(?!a[a-z]*-)\w+-)?456$";
string input = @"123-456
123-7-456
123-Apple-456
123-0-456
123-Alphabet-456";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}