const regex = /^123-(?:(?!a[a-z]*-)\w+-)?456$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^123-(?:(?!a[a-z]*-)\\w+-)?456$', 'gmi')
const str = `123-456
123-7-456
123-Apple-456
123-0-456
123-Alphabet-456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}