re = /^123-(?:(?!a[a-z]*-)\w+-)?456$/mxi
str = '123-456
123-7-456
123-Apple-456
123-0-456
123-Alphabet-456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end