$re = '/^123-(?:(?!a[a-z]*-)\w+-)?456$/mxi';
$str = '123-456
123-7-456
123-Apple-456
123-0-456
123-Alphabet-456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);