using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/([-a-z]+)-\d+";
string input = @"variety.com/2017/biz/news/tax-march-donald-trump-protest-1202031487/
variety.com/2017/biz/the/life/of/madam/green/news/tax-march-donald-trump-protest-1202031487/
variety.com/2017/biz/the/life/of/news/tax-march-donald-trump-protest-1202031487/the/days/of/our/lives
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}