import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/([-a-z]+)-\\d+";
final String string = "variety.com/2017/biz/news/tax-march-donald-trump-protest-1202031487/\n"
+ "variety.com/2017/biz/the/life/of/madam/green/news/tax-march-donald-trump-protest-1202031487/\n"
+ "variety.com/2017/biz/the/life/of/news/tax-march-donald-trump-protest-1202031487/the/days/of/our/lives\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}