// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/([-a-z]+)-\d+").unwrap();
let string = "variety.com/2017/biz/news/tax-march-donald-trump-protest-1202031487/
variety.com/2017/biz/the/life/of/madam/green/news/tax-march-donald-trump-protest-1202031487/
variety.com/2017/biz/the/life/of/news/tax-march-donald-trump-protest-1202031487/the/days/of/our/lives
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}