import re
regex = re.compile(r"/([-a-z]+)-\d+", flags=re.MULTILINE)
test_str = ("variety.com/2017/biz/news/tax-march-donald-trump-protest-1202031487/\n"
"variety.com/2017/biz/the/life/of/madam/green/news/tax-march-donald-trump-protest-1202031487/\n"
"variety.com/2017/biz/the/life/of/news/tax-march-donald-trump-protest-1202031487/the/days/of/our/lives\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")