re = /\/([-a-z]+)-\d+/m
str = 'variety.com/2017/biz/news/tax-march-donald-trump-protest-1202031487/
variety.com/2017/biz/the/life/of/madam/green/news/tax-march-donald-trump-protest-1202031487/
variety.com/2017/biz/the/life/of/news/tax-march-donald-trump-protest-1202031487/the/days/of/our/lives
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end