const regex = /Gi.+\s+(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Gi.+\\s+(\\d+)', 'gm')
const str = `"- Giảm giá 10790000đ
- PMH gia dụng 9600000đ hoặc Giảm 8000000đ
- Giảm thêm 7% khi mua cùng sản phẩm bất kỳ có giá cao hơn
- Mua 1 số Loa karaoke giảm đến 20%
- Mua kèm ỔN ÁP ROBOT giảm giá 12% (Không áp dụng KM khác)
- Mua kèm Ổn áp tự động 1 pha LiOA DRI giảm giá 12% (Không áp dụng KM khác)
- Tặng Bộ 3 ứng dụng giải trí trên TV"-`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);