using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""?([^""{]+)?""?\s*:\s*""([^""]+)?"",?";
string input = @"(function() {
'use strict';
//some configuration stuff (some other stuff may be insterted)
var translations = angular.module('module.translations.languages.enUs', []);
translations.constant('translationsName', {
""first_label"":""first_label_value"",
""second_label"" : ""second_label_value""
//etc
});
}());";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}