import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"?([^\"\\{]+)?\"?\\s*:\\s*\"([^\"]+)?\",?";
final String string = "(function() {\n"
+ " 'use strict';\n"
+ " //some configuration stuff (some other stuff may be insterted)\n"
+ " var translations = angular.module('module.translations.languages.enUs', []);\n\n"
+ " translations.constant('translationsName', {\n"
+ " \"first_label\":\"first_label_value\",\n\n"
+ " \"second_label\" : \"second_label_value\"\n"
+ " //etc\n"
+ "});\n\n"
+ "}());";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}