const regex = /"?([^"{]+)?"?\s*:\s*"([^"]+)?",?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"?([^"{]+)?"?\\s*:\\s*"([^"]+)?",?', 'g')
const str = `(function() {
'use strict';
//some configuration stuff (some other stuff may be insterted)
var translations = angular.module('module.translations.languages.enUs', []);
translations.constant('translationsName', {
"first_label":"first_label_value",
"second_label" : "second_label_value"
//etc
});
}());`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}