re = /"?([^"{]+)?"?\s*:\s*"([^"]+)?",?/
str = '(function() {
\'use strict\';
//some configuration stuff (some other stuff may be insterted)
var translations = angular.module(\'module.translations.languages.enUs\', []);
translations.constant(\'translationsName\', {
"first_label":"first_label_value",
"second_label" : "second_label_value"
//etc
});
}());'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end