using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"orderNumber : (?P<orderNumber>[^\s]+).*?orderType : (?P<orderType>[^\s]+).*?orderCompany : (?P<orderCompany>[^\s]+).*";
string input = @"orderNumber : 100 orderType : OP orderCompany : 00890";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}