package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)orderNumber : (?P<orderNumber>[^\s]+).*?orderType : (?P<orderType>[^\s]+).*?orderCompany : (?P<orderCompany>[^\s]+).*`)
var str = `orderNumber : 100 orderType : OP orderCompany : 00890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}