import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "orderNumber : (?P<orderNumber>[^\\s]+).*?orderType : (?P<orderType>[^\\s]+).*?orderCompany : (?P<orderCompany>[^\\s]+).*";
final String string = "orderNumber : 100 orderType : OP orderCompany : 00890";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}