const regex = /orderNumber : (?P<orderNumber>[^\s]+).*?orderType : (?P<orderType>[^\s]+).*?orderCompany : (?P<orderCompany>[^\s]+).*/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('orderNumber : (?P<orderNumber>[^\\s]+).*?orderType : (?P<orderType>[^\\s]+).*?orderCompany : (?P<orderCompany>[^\\s]+).*', 'gms')
const str = `orderNumber : 100 orderType : OP orderCompany : 00890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}