re = /orderNumber : (?P<orderNumber>[^\s]+).*?orderType : (?P<orderType>[^\s]+).*?orderCompany : (?P<orderCompany>[^\s]+).*/m
str = 'orderNumber : 100 orderType : OP orderCompany : 00890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end